Before posting, and to avoid disappointment, please read the following:

  • This forum is not for 2BrightSparks to provide technical support. It's primarily for users to help other users. Do not expect 2BrightSparks to answer any question posted to this forum.
  • If you find a bug in any of our software, please submit a support ticket. It does not matter if you are using our freeware, a beta version or you haven't yet purchased the software. We want to know about any and all bugs so we can fix them as soon as possible. We usually need more information and details from you to reproduce bugs and that is better done via a support ticket and not this forum.

Ignore Folders by Modified Date

For technical support visit https://support.2brightsparks.com/
Post Reply
JoshuaAce
Newbie
Newbie
Posts: 2
Joined: Sat Mar 25, 2017 12:03 am

Ignore Folders by Modified Date

Post by JoshuaAce »

I have a profile configured to monitor a folder [Source] for changes. When triggered it copies any new files that have been modified within the last 15 minutes out of the [Source] directory to a [Target] directory . The [Target] directory is a temporary repository for these files and gets emptied frequently by manual processes.

The [Source] directory needs to stay pristine, the ONLY changes it experiences is the addition of new folders and files.

The issue is, the profile copies over the entire directory structure from [Source], which results in thousands of empty folders each time the profile runs. It does successfully copy the files that have been modified within the configured 15 minutes :

Compare Options > Date & Time | Ignore files that have not been modified within the last 15 minutes

Any assistance will be greatly appreciated.

Thanks
JoshuaAce
Newbie
Newbie
Posts: 2
Joined: Sat Mar 25, 2017 12:03 am

Re: Ignore Folders by Modified Date

Post by JoshuaAce »

I may have figured this out.

Decisions - Files > Folders What to do if a directory exists on [SOURCE] but not on [TARGET] = Do nothing

I had this set to Automatic

I was under the impression that by selecting Do nothing, new files nested in directories would be ignore. That does not seem to be the case as my test was successful when set to Do nothing.
Post Reply