Before posting, and to avoid disappointment, please read the following:

  • This forum is not for 2BrightSparks to provide technical support. It's primarily for users to help other users. Do not expect 2BrightSparks to answer any question posted to this forum.
  • If you find a bug in any of our software, please submit a support ticket. It does not matter if you are using our freeware, a beta version or you haven't yet purchased the software. We want to know about any and all bugs so we can fix them as soon as possible. We usually need more information and details from you to reproduce bugs and that is better done via a support ticket and not this forum.

Unattended mode - "the user has not been authenticated" connecting to source

For technical support visit https://support.2brightsparks.com/
Post Reply
Mercury Systems
Newbie
Newbie
Posts: 3
Joined: Mon May 15, 2017 11:22 am

Unattended mode - "the user has not been authenticated" connecting to source

Post by Mercury Systems »

Hello all.
We're trialling Syncback Pro V7.6.64.0.
When backing up a SharePoint document store on Office 365 tenant, SBP cannot connect to source and logs "The operation being requested was not performed because the user has not been authenticated.
I have put the credentials in Network\Connection details for source and the Test Connection is successful.
If I run the profile manually in attended or unattended mode, it runs successfully, but if I run it scheduled, it fails with the above message.

Any suggestions greatly appreciated! :?:

regards,
Chris.
cliffhanger
Expert
Expert
Posts: 606
Joined: Tue May 31, 2011 5:59 pm

Re: Unattended mode - "the user has not been authenticated" connecting to source

Post by cliffhanger »

Hi, I guess your Subject meant to say 'Scheduled mode - the user [etc]', as your body text confirms it works Unattended if triggered manually?

At a guess it is related to the security context in which the profile is being run by the Windows Task Scheduler (i.e. 'as a batch job'). Can you provide a screen-grab of the opening tab ('Security') in the Edit Schedule dialog for the profile?

Please also confirm the version of Windows being used to run SyncBack...
Mercury Systems
Newbie
Newbie
Posts: 3
Joined: Mon May 15, 2017 11:22 am

Re: Unattended mode - "the user has not been authenticated" connecting to source

Post by Mercury Systems »

Hello Cliffhanger.

Firstly, thanks for your response.

Yep, you're right, sorry to all those that read my post and found that I'd fooled you!!

I can manually run the task in attended or un-attended mode. After a successful run, If reschedule for say a couple of minutes ahead of the current time, it fails. I've tried different settings in Network\Advanced (top 2 tick boxes), but nothing there fixes it.

The O/S is Windows SBS 2011 Std.

Attached (hopefully) are the security boxes along with the other bits I've tried.

KR,

Chris.
Attachments
Screenshots
Screenshots
SBP 7 issues.jpg (207.15 KiB) Viewed 4276 times
cliffhanger
Expert
Expert
Posts: 606
Joined: Tue May 31, 2011 5:59 pm

Re: Unattended mode - "the user has not been authenticated" connecting to source

Post by cliffhanger »

Beats me, too. I can't see any obvious reasons in your settings that would cause a problem. I did wonder if the manual runs that succeed do so by virtue of the fact that you were logged into the SBS server console already, and Windows was silently re-using an (i.e. your) existing connection/credentials, a combination which wasn't still in place by the time the scheduled trigger fires. But if you were still logged in to the console at the same time the 'in a couple of minutes' scheduled run tried (and it produced the same error), that seems unlikely.

Only thing I can suggest is submit a Support Zip with debug-out of an attempted scheduled run to 2BS, and see if they have any ideas.
Mercury Systems
Newbie
Newbie
Posts: 3
Joined: Mon May 15, 2017 11:22 am

Re: Unattended mode - "the user has not been authenticated" connecting to source

Post by Mercury Systems »

OK Cliffhanger, I'll send them a zip.

If I get a resolution, I'll post back here in case it's useful to others.

Thanks again for looking!

KR,

Chris.
Post Reply