Before posting, and to avoid disappointment, please read the following:

  • This forum is not for 2BrightSparks to provide technical support. It's primarily for users to help other users. Do not expect 2BrightSparks to answer any question posted to this forum.
  • If you find a bug in any of our software, please submit a support ticket. It does not matter if you are using our freeware, a beta version or you haven't yet purchased the software. We want to know about any and all bugs so we can fix them as soon as possible. We usually need more information and details from you to reproduce bugs and that is better done via a support ticket and not this forum.

Help with copying files modified in the last 30 days only

For technical support visit https://support.2brightsparks.com/
Post Reply
simonmason
Newbie
Newbie
Posts: 6
Joined: Sun Jan 25, 2009 2:11 pm

Help with copying files modified in the last 30 days only

Post by simonmason »

What am I doing wrong here? I want to ONLY copy files modified in the last 30 days from my NAS to a local drive. Thanks.

I set the options as you see here:
Screen Shot 2017-05-28 at 9.14.48 AM.png
Screen Shot 2017-05-28 at 9.14.48 AM.png (330.34 KiB) Viewed 2653 times
Yet when I run a simulated run it is picking a files that were clearly not modified in the last 30 days. An example is here:
Screen Shot 2017-05-28 at 9.14.08 AM.png
Screen Shot 2017-05-28 at 9.14.08 AM.png (424.2 KiB) Viewed 2653 times
cliffhanger
Expert
Expert
Posts: 606
Joined: Tue May 31, 2011 5:59 pm

Re: Help with copying files modified in the last 30 days only

Post by cliffhanger »

Hi, those aren't files, they are folders (at least, all the objects I can see are). The "Ignore files..." setting has no effect on them, because they're not files. Note that if you went ahead right now, only the folders would be copied AFAICS from your screenshot; if any of their contents were going to be copied, those contents (i.e. files) would be listed too (separately/individually) and you would be showing us a screen shot of those instead. I can see some files are due to be copied but you haven't included any details of them, however, if only 128 files are due to be copied (see bottom right of screenshot) and over 58000 are not, my guess is your rule is working fine, and those 128 are the files you want and the rest you do not...

At a guess, those folders' contents (files) are being ignored because the contents are older than your requirements/preferences, but that still leaves 'What to do with the folders?', and one option is to copy them. This happens to be the Automatic default for 'safety' ("when in doubt, copy it"). If you don't want them, then go to

Decisions - Files > Folders > top section > Do Nothing

This section (as mentioned in the contextual Help - press F1 on Folders page) is meant to deal with 'empty folders'. However, 'populated folders from which nothing is copied c/o various rules (hence, any copy of the folder would be empty)' are also handled here. Almost certainly those folders qualify for the latter because none of their contents are due to be copied c/o your age limit...
simonmason
Newbie
Newbie
Posts: 6
Joined: Sun Jan 25, 2009 2:11 pm

Re: Help with copying files modified in the last 30 days only

Post by simonmason »

Thanks. That sorted everything out.
Post Reply