Before posting, and to avoid disappointment, please read the following:

  • This forum is not for 2BrightSparks to provide technical support. It's primarily for users to help other users. Do not expect 2BrightSparks to answer any question posted to this forum.
  • If you find a bug in any of our software, please submit a support ticket. It does not matter if you are using our freeware, a beta version or you haven't yet purchased the software. We want to know about any and all bugs so we can fix them as soon as possible. We usually need more information and details from you to reproduce bugs and that is better done via a support ticket and not this forum.

Mirror not working as expected

For technical support visit https://support.2brightsparks.com/
Post Reply
Bassflute
Newbie
Newbie
Posts: 2
Joined: Tue Aug 30, 2016 8:38 am

Mirror not working as expected

Post by Bassflute »

Hi Folks,

I have a recurring problem with my mirror to USB setup here.

I have set it up as a mirror from hard disk to USB and it runs periodically (e.g. on the hour). In this way, it offers security against a disk crash happening from one disk image to another (which runs nightly). Plus versioning gives me a bit of leeway if I accidentally trash a file.

What is odd is that SyncBack regularly "re-mirrors" whole swathes of files even though they haven't changed for months or years. I am currently waiting for just such a sync to finish as it is going through 180+ GB of files. This time, I also decided to look at what it is doing.

It is simply going into every directory, resetting the directory date and then deleting and copying over every individual file (with unchanged date).

If I look at the source directory on my hard disk, it says e.g. 1 August 2016 while the target directory on the USB disk now says 27 July 2017 (today's date).

This is absolutely counter-intuitive and also entirely wrong: I do NOT want different folder dates on my USB disk as this might well screw up any restore if I have no idea when the directory was created!

Is there some setting I have set that could be causing this or is this a bug?

My settings are pretty simple:

Code: Select all

Files will be mirrored from Source (T:\) to Destination (E:\KAPOK\SyncBackPro\).
If the same file has been changed on both Destination and Source then the file on Source will replace the file on Destination.
Files only on Destination are deleted.
Files only on Source are copied to Destination.
If an empty directory is only on Destination then the decision is automated.
If an empty directory is only on Source then the decision is automated.
The log file will be emailed after the profile has run (but only if the profile run fails).
The following files/folders will be ignored: *\$RECYCLE.BIN\,*\*.SBSECOR,"*\AppData\Local\Temporary Internet Files\",*\AppData\Local\Temp\,"*\Application Data\Mozilla\Firefox\Profiles\*\parent.lock",*\desktop.ini,*\DfsrPrivate\,"*\Local Settings\Temporary Internet Files\","*\Local Settings\Temp\","*\Microsoft\Windows\Temporary Internet Files\",*\RECYCLER\,*\SBSE____.*,"*\System Volume Information\",*\System32\Msdtc\MSDTC.LOG,*\thumbs.db,*\Windows\csc\,*\Windows\debug\NtFrs*,*\Windows\ntfrs\jet\,*\Windows\Prefetch\,*\Windows\Registration\*.crmlog,*\Windows\sysvol\domain\DO_NOT_REMOVE_NtFrs_PreInstall_Directory\,*\Windows\sysvol\domain\NtFrs_PreExisting___See_EventLog\,*\Windows\sysvol\staging\domain\NTFRS_*,*\Windows\Temp\,\#recycle*,\hiberfil.sys,\pagefile.sys,\PGPWDE01
The profile is stored in C:\Users\Bassflute\AppData\Local\2BrightSparks\SyncBackPro\
Swapna
2BrightSparks Staff
2BrightSparks Staff
Posts: 993
Joined: Mon Apr 13, 2015 6:22 am

Re: Mirror not working as expected

Post by Swapna »

Hi,
It is simply going into every directory, resetting the directory date and then deleting and copying over every individual file (with unchanged date).
Please submit a support zip (with debug logs) of your profile configuration and a screen shot of the Differences Window pointing to an unchanged file for further investigation. Full instructions to create and submit a support zip are given here:

http://support.2brightsparks.com/knowle ... ation-file

If your Zip is over 30MB, contact us for alternate instructions, advising the actual size. Do not try to attach to the ticket!

Do not post (nor links to) Support Zips on this open forum.
If I look at the source directory on my hard disk, it says e.g. 1 August 2016 while the target directory on the USB disk now says 27 July 2017 (today's date).
There is a non-default option in SyncBackPro to preserve the Created stamp for folders, which is under:

Modify profile > Expert mode > Copy/Delete > Folders > 'Copy sub-directory attributes and creation date (only when new directories are created)'

As stated in the help file, this option copies the creation date when new directories are created, but it can't update the creation date/ time stamps for already copied folders. This option must be in force before/at the time the new copy was created. However, there is no option to set the last modified date/time stamp of a folder, as it is controlled by Windows. Please read this forum post for additional details:

viewtopic.php?t=5593

Thank you.
Post Reply