Before posting, and to avoid disappointment, please read the following:

  • This forum is not for 2BrightSparks to provide technical support. It's primarily for users to help other users. Do not expect 2BrightSparks to answer any question posted to this forum.
  • If you find a bug in any of our software, please submit a support ticket. It does not matter if you are using our freeware, a beta version or you haven't yet purchased the software. We want to know about any and all bugs so we can fix them as soon as possible. We usually need more information and details from you to reproduce bugs and that is better done via a support ticket and not this forum.

Task scheduler fails with 2147943726 if Do not store password is unchecked

For technical support visit https://support.2brightsparks.com/
Post Reply
mikeprince
Newbie
Newbie
Posts: 1
Joined: Thu Jun 24, 2010 12:59 pm

Task scheduler fails with 2147943726 if Do not store password is unchecked

Post by mikeprince »

I have been trying lots of things to sort this, but to no avail. This is using the latest version of SyncBack Pro on Windows 10 Pro.

My scheduled tasks do not run. I got a new PC a little while ago and I think they have probably never run on this, whereas for years with seemingly the same setup and account on a different PC I had no issues. The task scheduler gives "Task Scheduler failed to start "\2BrightSparks\SyncBackProx64\MIKE-SP4-mike\SyncBackPro Test" task for user "MIKE-SP4\mike". Additional Data: Error Value: 2147943726". My machine is MIKE-SP4 and account is an Administrator and Microsoft account (identified by email address but correctly shown without the domain here).

I have set up a simple new profile to test and get the same error. Similary if I run it directly from Task Scheduler. If I edit the task directly via Task Scheduler and check "Do not store password" it does however run correctly. Similarly if I have the task set to "Run only when user is logged on" it works. The password I enter after changing the task is correct: an invalid one is not accepted at this point anyway. If I change the user to SYSTEM the task also runs. I wondered whether this suggests that there must be some privilege my account is lacking, but I have been through everything at http://support.2brightsparks.com/knowle ... uler-fails, as well as many discussions elsewhere, and all seems fine.

I realise this isn't directly a SyncBack problem, but since SyncBack does not allow "Do not store password" to be checked (it is greyed out), and clears it if it was, I can't use SyncBack to schedule, or change a schedule, for any profile.
Swapna
2BrightSparks Staff
2BrightSparks Staff
Posts: 992
Joined: Mon Apr 13, 2015 6:22 am

Re: Task scheduler fails with 2147943726 if Do not store password is unchecked

Post by Swapna »

Hi,

Please export and send your profile configuration, and the screenshots of ‘General’ and ‘History’ pages from:

Control Panel > Task Scheduler > Task Scheduler Library > 2BrightSparks > SyncBackPro > 'User Name/Computername' > select the task from the centre panel

to [email protected] for assistance.

Thank you.
Post Reply