Before posting, and to avoid disappointment, please read the following:

  • This forum is not for 2BrightSparks to provide technical support. It's primarily for users to help other users. Do not expect 2BrightSparks to answer any question posted to this forum.
  • If you find a bug in any of our software, please submit a support ticket. It does not matter if you are using our freeware, a beta version or you haven't yet purchased the software. We want to know about any and all bugs so we can fix them as soon as possible. We usually need more information and details from you to reproduce bugs and that is better done via a support ticket and not this forum.

How to set up source folder that requires admin access in Windows

For technical support visit https://support.2brightsparks.com/
Post Reply
Vocalpoint
Enthusiastic
Enthusiastic
Posts: 19
Joined: Mon Jul 13, 2009 5:51 pm

How to set up source folder that requires admin access in Windows

Post by Vocalpoint »

All

I need to build out a profile that actually copies the Syncback Tasks I create for Syncback that appear in c:\Windows\System32\Tasks. In a rebuild situation - it is much easier to simply rename these files to an .xml extension and reimport them via Task Scheduler rather than having to recreate them all the time. I have about 30 profiles and this takes merely a minute to reset if needed.

But this directory (C:\Windows\System32\Tasks\2BrightSparks\SyncBackPro)is restricted (and hidden) and when I start a new profile and browse out to this location as a "source" - it cannot be seen. I even tried copying the folder path and pasting it into the source field but even that does not work.

Is there a setting in Syncback somewhere that lets me browse into any hidden location (or prompts me for admin creds) so I can set that restricted folder location as a source?

Cheers,

VP
Swapna
2BrightSparks Staff
2BrightSparks Staff
Posts: 992
Joined: Mon Apr 13, 2015 6:22 am

Re: How to set up source folder that requires admin access in Windows

Post by Swapna »

Hi,

There is no issue accessing the folder path "C:\Windows\System32\Tasks\2BrightSparks\SyncBackPro\" via SyncBackPro on my end. Can you try accessing the folder through Window File Explorer and see if it works?

Thank you.
Vocalpoint
Enthusiastic
Enthusiastic
Posts: 19
Joined: Mon Jul 13, 2009 5:51 pm

Re: How to set up source folder that requires admin access in Windows

Post by Vocalpoint »

Swapna wrote:
Fri May 21, 2021 5:42 am
There is no issue accessing the folder path "C:\Windows\System32\Tasks\2BrightSparks\SyncBackPro\" via SyncBackPro on my end. Can you try accessing the folder through Window File Explorer and see if it works?
Thanks for the update. To your question - I can see everything just fine via Explorer:
2021-05-21_6-41-35.png
2021-05-21_6-41-35.png (62.58 KiB) Viewed 1071 times
But when I go to setup a new Profile and attempt to set the Source to C:\Windows\System32\Tasks - I see this:
2021-05-21_6-42-49.png
2021-05-21_6-42-49.png (31.53 KiB) Viewed 1071 times
I cannot see anything BUT the Microsoft folder - which is of no use to me in this scenario. It's almost as if SyncBack is being forced to play along with some file/folder permissions OR is running non-admin - and restricting the view.

I am local admin on this machine and logically the views (and file selection) between Windows Explorer and SyncBack Pro should be identical - regardless of what folder I choose to set as Source.

Appreciate another look at this when you have a sec.

Cheers

VP
Swapna
2BrightSparks Staff
2BrightSparks Staff
Posts: 992
Joined: Mon Apr 13, 2015 6:22 am

Re: How to set up source folder that requires admin access in Windows

Post by Swapna »

Hi,

Please submit a support ticket to [email protected] for investigation.

Thank you
Post Reply