Before posting, and to avoid disappointment, please read the following:

  • This forum is not for 2BrightSparks to provide technical support. It's primarily for users to help other users. Do not expect 2BrightSparks to answer any question posted to this forum.
  • If you find a bug in any of our software, please submit a support ticket. It does not matter if you are using our freeware, a beta version or you haven't yet purchased the software. We want to know about any and all bugs so we can fix them as soon as possible. We usually need more information and details from you to reproduce bugs and that is better done via a support ticket and not this forum.

Task scheduler problem in Windows 10 Anniversary Update (10.0.14393)

For technical support visit https://support.2brightsparks.com/
Post Reply
Mossbrucker
Newbie
Newbie
Posts: 2
Joined: Tue Aug 16, 2016 8:42 am

Task scheduler problem in Windows 10 Anniversary Update (10.0.14393)

Post by Mossbrucker »

For a long time I used a profile in SyncBackSE7/Win10 to backup data, repeating every 1 day, every 1 hour.
Since the update to Windows 10 Anniversary Update and to SyncBackSE V7.6.28.0 the task doesn't run without an error. But when i change the task to "run only every 1 day" it does run.
The checkbox "Run interactively if user logged on" is unticked.

Any idea what could be wrong?
cliffhanger
Expert
Expert
Posts: 606
Joined: Tue May 31, 2011 5:59 pm

Re: Task scheduler problem in Windows 10 Anniversary Update (10.0.14393)

Post by cliffhanger »

I don't yet have W10AU, so can't get into this in-depth (cannot test, etc.) but I did find this with a quick Google, which to me sounds very similar (especially as you didn't mention any error message, and the hit mentions 'silently'). The dialogue suggests MS may eventually give in and admit it might be a bug (while everyone else needs less persuading...). There are a couple of suggested workarounds you can maybe try. Good luck (and if you find some other fix, maybe post back?)
mcrew
Newbie
Newbie
Posts: 1
Joined: Wed Aug 17, 2016 12:57 pm

Re: Task scheduler problem in Windows 10 Anniversary Update (10.0.14393)

Post by mcrew »

The task scheduler problem occurred on all of my machines "upgraded" with the Win10 Anniversary Update. The problem appears to be that customized folders in Task Scheduler are not recognized or found by the OS.

The fix is simple. In Task Scheduler, export all scheduled tasks in the 2BrightSparks folder. Then, make a new folder under Task Scheduler Library (e.g., SyncBack), and import into that new folder the tasks you exported. (No, you can't just drag or move the tasks from one TS folder to another.) Delete the old folder so you don't have task duplication when MS issues a patch to fix this problem.
Kostas
2BrightSparks Staff
2BrightSparks Staff
Posts: 368
Joined: Thu Sep 18, 2014 2:08 am

Re: Task scheduler problem in Windows 10 Anniversary Update (10.0.14393)

Post by Kostas »

mcrew wrote:The task scheduler problem occurred on all of my machines "upgraded" with the Win10 Anniversary Update. The problem appears to be that customized folders in Task Scheduler are not recognized or found by the OS.

The fix is simple. In Task Scheduler, export all scheduled tasks in the 2BrightSparks folder. Then, make a new folder under Task Scheduler Library (e.g., SyncBack), and import into that new folder the tasks you exported. (No, you can't just drag or move the tasks from one TS folder to another.) Delete the old folder so you don't have task duplication when MS issues a patch to fix this problem.
Hi,

Your solution may work but it would cause SyncBack not to be able to "see" the scheduled tasks in their new folder since SyncBack is aware only of tasks in its own task folder. The proper way to go with this is to export all the tasks from inside the SyncBack task folder under the Task Schedule Library in the Windows Task Scheduler, then delete the tasks inside the SyncBack task folder and the folders themselves, then run SyncBack so it can recreate the task folders and finally import the scheduled tasks back in.

Thanks,
Kostas
[2bs]
Mossbrucker
Newbie
Newbie
Posts: 2
Joined: Tue Aug 16, 2016 8:42 am

Re: Task scheduler problem in Windows 10 Anniversary Update (10.0.14393)

Post by Mossbrucker »

Hej,
I have now tested different settings; the result:
- profiles that are to be executed once a day to run, so do
- profiles that are to be executed several times a day, are executed only once to the first specified time; to the other times, nothing happens
- no error message
whitets
Newbie
Newbie
Posts: 1
Joined: Sun Mar 01, 2015 10:53 pm

Re: Task scheduler problem in Windows 10 Anniversary Update (10.0.14393)

Post by whitets »

My automatic backups also stopped working with Win10 Anniversary update. I tried several things posted here, but it still wouldn't work. When I tried to reset/change the schedule, Syncback wouldn't recognize my windows password. So I tried deleting the schedule for the backup then recreating a new one and it works just fine now.
ema02
Newbie
Newbie
Posts: 3
Joined: Tue Oct 04, 2016 10:00 am

Re: Task scheduler problem in Windows 10 Anniversary Update (10.0.14393)

Post by ema02 »

Hi,
several profiles executing fine on my PC.

However, when trying to define a schedule, SyncBackPro prompts me for my Windows password and rejects it (although it was properly entered).
An error message appears: "Das System kann den angegebenen Pfad nicht finden".
In English (my translation): "The system can't find the specified path". Which path??

I tested with different users (Admin and restricted user) and profiles. Same system behaviour in all cases.

in Task Scheduler the 2BrightSparks subfolders are empty.
So I'm stuck without being able to define my very first scheduled profile.

Any ideas how to solve this problem? (Suggestions provided so far in this Forum unfortunately not leading to success in my case).

SyncbackPro V7.6.36.0
Windows 10 Home 64, Version 1607, Build 14393.222

Regards, Ernst
Kostas
2BrightSparks Staff
2BrightSparks Staff
Posts: 368
Joined: Thu Sep 18, 2014 2:08 am

Re: Task scheduler problem in Windows 10 Anniversary Update (10.0.14393)

Post by Kostas »

ema02 wrote:Hi,
several profiles executing fine on my PC.

However, when trying to define a schedule, SyncBackPro prompts me for my Windows password and rejects it (although it was properly entered).
An error message appears: "Das System kann den angegebenen Pfad nicht finden".
In English (my translation): "The system can't find the specified path". Which path??

I tested with different users (Admin and restricted user) and profiles. Same system behaviour in all cases.

in Task Scheduler the 2BrightSparks subfolders are empty.
So I'm stuck without being able to define my very first scheduled profile.

Any ideas how to solve this problem? (Suggestions provided so far in this Forum unfortunately not leading to success in my case).

SyncbackPro V7.6.36.0
Windows 10 Home 64, Version 1607, Build 14393.222

Regards, Ernst
Hi,

Have you tried the suggestion from this KB article: http://support.2brightsparks.com/knowle ... file-error ?

Thanks,
Kostas
[2bs]
ema02
Newbie
Newbie
Posts: 3
Joined: Tue Oct 04, 2016 10:00 am

Re: Task scheduler problem in Windows 10 Anniversary Update (10.0.14393)

Post by ema02 »

Hi Kostas,
thanks for your suggestion.
I'll try it asap and subsequently I'll post success/failure.
Regards
Ernst
ema02
Newbie
Newbie
Posts: 3
Joined: Tue Oct 04, 2016 10:00 am

Re: Task scheduler problem in Windows 10 Anniversary Update (10.0.14393)

Post by ema02 »

My problem solved. Thanks a lot, Kostas.
Regards
Ernst
Post Reply