Before posting, and to avoid disappointment, please read the following:

  • This forum is not for 2BrightSparks to provide technical support. It's primarily for users to help other users. Do not expect 2BrightSparks to answer any question posted to this forum.
  • If you find a bug in any of our software, please submit a support ticket. It does not matter if you are using our freeware, a beta version or you haven't yet purchased the software. We want to know about any and all bugs so we can fix them as soon as possible. We usually need more information and details from you to reproduce bugs and that is better done via a support ticket and not this forum.

SyncBackFree on Windows 10 and 8.1

SyncBackFree is the freeware version of SyncBack. It is *not* an evaluation version of SyncBackPro/SE.
Post Reply
Bootlebarth
Newbie
Newbie
Posts: 1
Joined: Tue Aug 04, 2015 4:09 pm

SyncBackFree on Windows 10 and 8.1

Post by Bootlebarth »

I have been using SyncBack on Vista for a while but on 8.1 and 10 it will only run once. You need to restart windows to allow another single run.

I have been through the compatibility process but no no avail - would an upgrade to Pro solve this problem?
cliffhanger
Expert
Expert
Posts: 606
Joined: Tue May 31, 2011 5:59 pm

Re: SyncBackFree on Windows 10 and 8.1

Post by cliffhanger »

Hi, which version (7.x.x.x) of Free are you using? There was a bug accidentally introduced a little while ago that combined with some default 'hide systray icon for non-MS apps' behavior by Windows (7-onward, so you wouldn't have seen that in Vista) - details here (read all the way down & follow that link to the Win-7-and-later tray syndrome). I guess from the absence of follow-up, this fixed it for that OP.

As shown here, it was fixed in v7.3.1.29, so an update to anything later than that should work. 7.3.3.6 certainly doesn't 'not reappear' in Windows 8.1 for me if I set its tray icon to 'only show notifications'; even though the tray icon is then/thus hidden unless you Show Hidden Icons, it correctly 'restores from tray' if you try to start another instance.

It's unlikely the SE or Pro version would behave differently (except that installing them would likely get the latest version, which has the 'restore from tray' bug-fix, so no issue). However, you can install either of them in parallel with Free (do not try to install to the same folder!) and try them free for 30 days to check. Neither the install nor any uninstall of SE/Pro would affect your Free install/config.
ccwhatley
Newbie
Newbie
Posts: 1
Joined: Fri Oct 16, 2015 7:02 pm

Re: SyncBackFree on Windows 10 and 8.1

Post by ccwhatley »

Sorry if this is not the correct place to post - upon searching for this issue, nothing came up... I am having a problem with SyncBack Free since upgrading from Windows 7 Pro to Windows 10 Pro... The problem being... I had SBF installed on the PC and it had been working properly. After the upgrade to WIn 10 - I noticed SBF was missing so I downloaded the latest version - yesterday - and installed it. Upon trying to set it up, when I clicked "When" to setup a schedule, I was prompted for the windows password - typed it in correctly - clicked "OK" - received error message "Access Denied". Some research shows this error was corrected in a previous version so I feel stumpted.
Please Advise.
Thank you! :-)
mickyj
2BrightSparks Staff
2BrightSparks Staff
Posts: 470
Joined: Mon Jan 05, 2004 6:51 pm

Re: SyncBackFree on Windows 10 and 8.1

Post by mickyj »

HI, do you have the checkbox "Do not store password" ticked for the schedule? If so, try unticking it. It looks like with Windows 10 you cannot use that option unless you are an administrator. SyncBackFree doesn't run elevated and so cannot use that option.
johnp
Newbie
Newbie
Posts: 1
Joined: Fri Jul 29, 2016 8:28 pm

Re: SyncBackFree on Windows 10 and 8.1

Post by johnp »

I have a similar problem. After installing windows 10, my profiles were no longer scheduled. To set them up again, I clicked on When, then Edit Schedule. A box appears that says there is no schedule profile for me and I'm asked if I want to create one. I click on yes. I am then prompted for my Windows logon password. After I enter it I get: The system cannot find the file specified.

Thank you
cliffhanger
Expert
Expert
Posts: 606
Joined: Tue May 31, 2011 5:59 pm

Re: SyncBackFree on Windows 10 and 8.1

Post by cliffhanger »

Hi, by the fact you didn't mention any re-install of SyncBack, I am guessing your Windows 10 changeover was actually an upgrade (over the top of Win8?), not a clean 'install'? It sounds like the upgrade process has fouled up regarding some file or other involved with the Windows Task Scheduler (or, the means of programmatically communicating with it - possibly part of SyncBack, possibly part of Windows). The fact that you lost your Schedules (which are stored as Window objects) but not your profiles (stored as SB objects) reinforces that general 'Windows stumbled' probability.

You can eliminate the possibility of any SB components being damaged by simply downloading the latest version and installing it 'over the top' of the existing SB install (this doesn't affect any profiles, it will only replace all the 'factory' components of SB). Then, try again. (BTW, you didn't supply your actual SB version number x.x.x.x [-X but the above should ensure it is latest official release 7.6.18.0)

If you still have problems, it sounds like you have an issue with Windows itself (either missing file or path - are you sure that Windows error mentions 'file', and not 'path'? - it could be important). Have you tried checking if you can create a Scheduled Task manually in Windows - for example, Schedule a Task to start Notepad in 2 minutes from 'now'? It may be necessary to try several times with different options to try and trigger an error, so I suggest use the 'Create Task' option, not 'Create Basic Task', as the former exposes many more options (and it may be one of these that triggers the error). There are too many permutations to list here, but I suggest you generally include the options 'Run whether user is logged on or not' and 'Configure for [Windows 10]' (you may find the default is for 'Vista', for example). Note that you will need to switch tabs in the Schedule dialog to fill in all the required options - see here for more info

Notes:

you don't (shouldn't?) need to supply the path to Notepad.exe on the Action tab, as its path is covered by your Windows PATH variable - which is why I suggested using Notepad to test

if you get as far as creating a Task, and want to check if it actually works (starts Notepad, etc) you may need to fire up Task Manager (right-click Taskbar > select option) and look under Background Processes under N - because the Task Scheduler may well start Notepad in session-0, so that it's not visible on your desktop (if so, you can close it from Task Manager by right-click entry > End Task)

I suggest you avoid the setting 'Do not store password' if you can, based on earlier posts in this thread. I think something about this has been fixed, but it could be it just fails more gracefully (or, it's locked off in SB's drilldown interface, etc). It shouldn't be necessary to use this just to test the basic WindowsTask Scheduler functionality works (or doesn't)
cliffhanger
Expert
Expert
Posts: 606
Joined: Tue May 31, 2011 5:59 pm

Re: SyncBackFree on Windows 10 and 8.1

Post by cliffhanger »

...look under Background Processes under N...
i.e. to see whether it worked
laguest
Newbie
Newbie
Posts: 2
Joined: Sat Jul 30, 2016 8:38 pm

Re: SyncBackFree on Windows 10 and 8.1

Post by laguest »

I am having the same issue.

I did perform an upgrade from Windows 8 to 10, then I upgrade SyncBackPro to ver 7.

I don't have a password set for my account and there is only one account on the system. The account does have admin rights.
When I log into the system I don't have to enter a password.

I did setup a scheduled task to start notepad, and this did work fine.

What happens to me is I have a profile that I want to setup a schedule for.
When I select the profile and then try to make a schedule I get the below info which I cant get past.

"Enter your Windows logon password for HPLaptop\My User Name. If you do not have a password simple press OK."
I click "OK" and then I get a popup that says "The system cant find the specified file"
I click on "OK" and I get the same error above about the login
Kostas
2BrightSparks Staff
2BrightSparks Staff
Posts: 368
Joined: Thu Sep 18, 2014 2:08 am

Re: SyncBackFree on Windows 10 and 8.1

Post by Kostas »

laguest wrote:I am having the same issue.

I did perform an upgrade from Windows 8 to 10, then I upgrade SyncBackPro to ver 7.

I don't have a password set for my account and there is only one account on the system. The account does have admin rights.
When I log into the system I don't have to enter a password.

I did setup a scheduled task to start notepad, and this did work fine.

What happens to me is I have a profile that I want to setup a schedule for.
When I select the profile and then try to make a schedule I get the below info which I cant get past.

"Enter your Windows logon password for HPLaptop\My User Name. If you do not have a password simple press OK."
I click "OK" and then I get a popup that says "The system cant find the specified file"
I click on "OK" and I get the same error above about the login
Hi,

1. Please check if you have any existing schedule tasks created in the Task Scheduler under:

Administrative Tools > Task Scheduler > Task Scheduler Library > 2BrightSparks > SyncBackPro > 'User Name'

If so, please verify if there are any errors displayed in the Task Scheduler - which might give you some clues to resolve the issue.

2. You can try deleting all the existing Schedule tasks and recreate them from SyncBackPro and see if it helps.

If things don't work out then please send an email to [email protected]

Thanks,
Kostas
[2bs]
eXpi
Newbie
Newbie
Posts: 1
Joined: Wed Aug 03, 2016 10:13 pm

Re: SyncBackFree on Windows 10 and 8.1

Post by eXpi »

I had this same problem with Syncback Pro and after Windows 8.1 to 10 upgrade. The problem was that for some reason the user account does not have permissions to the folders in Task Scheduler where Syncback stores its tasks. I couldn't delete the Syncback folder tree in task scheduler, even with administrator rights.

I solved this problem by deleting the 2BrightSparks registry key tree in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree

You might also need to delete the tasks in c:\windows\system32\tasks folder.

I hope this is useful to someone!
laguest
Newbie
Newbie
Posts: 2
Joined: Sat Jul 30, 2016 8:38 pm

Re: SyncBackFree on Windows 10 and 8.1

Post by laguest »

Thanks eXpi,

What you did worked for me.....

I solved this problem by deleting the 2BrightSparks registry key tree in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree

You might also need to delete the tasks in c:\windows\system32\tasks folder.
mickyj
2BrightSparks Staff
2BrightSparks Staff
Posts: 470
Joined: Mon Jan 05, 2004 6:51 pm

Re: SyncBackFree on Windows 10 and 8.1

Post by mickyj »

Thanks for posting this. We've created a KB article:

http://support.2brightsparks.com/knowle ... file-error
SBFUser
Newbie
Newbie
Posts: 3
Joined: Wed Oct 05, 2016 1:20 am

Re: SyncBackFree on Windows 10 and 8.1

Post by SBFUser »

If you don't want to edit the registry, I resolved this problem in Windows 10 by uninstalling SB from the Control Panel (right click the Start button > Control Panel > Programs and Features > SyncBack.
Either right click SyncBack and click uninstall or select uninstall next to Organize at the top of the list of installed programs.
Install the latest version of SB. As a convenience, I downloaded the latest update and saved the .exe file
Kostas
2BrightSparks Staff
2BrightSparks Staff
Posts: 368
Joined: Thu Sep 18, 2014 2:08 am

Re: SyncBackFree on Windows 10 and 8.1

Post by Kostas »

SBFUser wrote:If you don't want to edit the registry, I resolved this problem in Windows 10 by uninstalling SB from the Control Panel (right click the Start button > Control Panel > Programs and Features > SyncBack.
Either right click SyncBack and click uninstall or select uninstall next to Organize at the top of the list of installed programs.
Install the latest version of SB. As a convenience, I downloaded the latest update and saved the .exe file
Keep in mind that by doing this you will lose existing profiles and settings since an uninstall will remove these as well.

Thanks,
Kostas
[2bs]
SBFUser
Newbie
Newbie
Posts: 3
Joined: Wed Oct 05, 2016 1:20 am

Re: SyncBackFree on Windows 10 and 8.1

Post by SBFUser »

Editing the registry and deleting the Windows folder (as below) resulted in all my profiles being deleted; therefore, either deleting the SyncBack program or editing the registry and deleting the Windows folder gave the same result for me.

-Using the registry editor in Windows, delete the key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree\2BrightSparks

- Delete the folder C:\Windows\System32\Tasks\2BrightSparks
Post Reply