Before posting, and to avoid disappointment, please read the following:

  • This forum is not for 2BrightSparks to provide technical support. It's primarily for users to help other users. Do not expect 2BrightSparks to answer any question posted to this forum.
  • If you find a bug in any of our software, please submit a support ticket. It does not matter if you are using our freeware, a beta version or you haven't yet purchased the software. We want to know about any and all bugs so we can fix them as soon as possible. We usually need more information and details from you to reproduce bugs and that is better done via a support ticket and not this forum.

New subfolders get included rather than specified subfolders

SyncBackFree is the freeware version of SyncBack. It is *not* an evaluation version of SyncBackPro/SE.
Post Reply
vanguardlh
Newbie
Newbie
Posts: 3
Joined: Sat Nov 05, 2016 7:27 pm

New subfolders get included rather than specified subfolders

Post by vanguardlh »

Syncback 7.6.28.0
Windows 7 Home x64 SP-1

I specify which directories (folders) to include in a sync/backup. Those are the only paths that I want included in the sync/backup. That is for now and forever after - until I decide otherwise. SyncBack does not comply with my choices. If a new folder gets created (under the source path specified for the sync/backup), SyncBack then includes that new folder in a sync/backup. I never specified that new folder for inclusion.

How do I get SyncBack to use ONLY the choices that I have actually specified and NEVER include any new folders that were created after the sync/backup job was defined in SyncBack? I pick a root path, I pick the subdirectories, and that's all I ever want included. Anything new at the root is not automatically included. Why let me specify the subdirectories if the program doesn't actually use that list?

For example, the source path is D:\. I then click on "Choose sub-directories and files". I pick the subdirectories that I want included. I don't want any files immediately under the root (D:\). I don't want to include any new subdirectories created after I defined the sync job. I only want the specified subdirectories to get included and then anything new only under there. I specify the root folder only because from there are the subfolders that I do want included in the sync. I don't want any files under the root folder included. I definitely do not want any new subfolders included. I only want new/changed files under the specified subfolders to get included.

Do I have to create a separate sync job for each subfolder? I deselect the root folder. It and everything under it are deselected. Then I click on the subfolder that I do want to include. The problem is that the root folder gets selected, too. That's not what I want. I don't want files under the root folder to be included. Apparently the selector not only includes new files under the root but also new subfolders. That's why I first deselected the root folder and hoped only the subfolder(s) could be selected.

Do I have to deselect everything under the root folder and then use a filter, one for each wanted subfolder, to specify which ones to include? Since the root folder is the drive's root (D:\), would I specify "\folder\*" or "folder\*" (no leading slash) for the filter?
vanguardlh
Newbie
Newbie
Posts: 3
Joined: Sat Nov 05, 2016 7:27 pm

Re: New subfolders get included rather than specified subfolders

Post by vanguardlh »

I deselected everything in the folders tree; i.e., nothing selected for inclusion in the sync job. I then defined filters, like "\folder\*" hoping only the subfolder contents would get included in the sync job. Alas, the tree list ended up selecting the root folder (D:\) along with the specified subfolder. So filters (when specifying just folders) as selecting folders in the tree list.

Looks like I will have to create a separate sync job for each folder and then group them and run the sync on the group.
Swapna
2BrightSparks Staff
2BrightSparks Staff
Posts: 992
Joined: Mon Apr 13, 2015 6:22 am

Re: New subfolders get included rather than specified subfolders

Post by Swapna »

Hi,

Note that when you select a sub-folder under the root, the root folder will be automatically selected (in other words, if you select a child folder then its parent folder will be selected). However, you can configure the "Choose sub-directories and files" to ignore new files/folders created under the root and only include new files/folders created under a sub-folder 'folder 1'. You can do this by selecting "Ignore new file/folder" or "Include new file/folder" option from the dropdown list on the top-right of:

Modify > Simple > "Choose sub-directories and files" settings page

Then SyncBack will ignore any new files/folders created immediately under the root path but includes file/folders created under folder1.

For example: If you have configured 'Choose sub-directories and files' settings page as below:

\ (root) --> Ignore new file/folder
folder 1 --> Include new file/folder

and if you create 'folder 2' immediately under the root then it will be ignored from the backup selection.

\
folder 1
folder 2 --> it will be shown in the tree structure, but will be deselected from backup

But if you create 'folder 2' under 'folder 1' then it will be included in the backup selection.

\
folder 1
- folder 2 --> it will be shown in the tree structure and will be selected for backup (as 'folder 1' is configured to 'Include new file/folders')

Note that the same logic applies to files as well, which you can try to see if it helps to resolve your issue.

Thank you.
vanguardlh
Newbie
Newbie
Posts: 3
Joined: Sat Nov 05, 2016 7:27 pm

Re: New subfolders get included rather than specified subfolders

Post by vanguardlh »

Still took awhile to see what you were suggesting. I was in the tree list for "Choose sub-directories and files" but still could not see how to ignore files or folders - until I happen to click on the "Include new files". THEN I get a drop-down list. Same for folders.

This is very bad GUI design. Way back in the Windows 3.x days, a drop-down list is signified by showing a downward chevron at the right end of the selection. Then clicking on the selection or chevron would expand the list. There is supposed to be an indication that there is a drop-down list, not having the user find it by accident. I did not see the drop-down lists because they are not shown as drop-down lists.

Thanks for the help on exposing the hidden drop-down lists.
Post Reply