Before posting, and to avoid disappointment, please read the following:

  • This forum is not for 2BrightSparks to provide technical support. It's primarily for users to help other users. Do not expect 2BrightSparks to answer any question posted to this forum.
  • If you find a bug in any of our software, please submit a support ticket. It does not matter if you are using our freeware, a beta version or you haven't yet purchased the software. We want to know about any and all bugs so we can fix them as soon as possible. We usually need more information and details from you to reproduce bugs and that is better done via a support ticket and not this forum.

Backup not finding sub folders

SyncBackFree is the freeware version of SyncBack. It is *not* an evaluation version of SyncBackPro/SE.
Post Reply
Mike_b
Newbie
Newbie
Posts: 1
Joined: Sat Dec 29, 2018 11:09 pm

Backup not finding sub folders

Post by Mike_b »

I am setting up a backup from a mapped network drive to an attached USB hard drive. The mapped network drive is a Onedrive documents folder with all its sub-directories on another PC on the same local network. Both PCs are running Windows 10. From File Explorer I can see all the subfolders on the source drive. When I set up a backup job using Syncbackfree and click Choose sub-directories and files I can see the files in the root directory but I don't see any sub-directories and so of course none are backed up. Any suggestions?
Swapna
Expert
Expert
Posts: 1010
Joined: Mon Apr 13, 2015 6:22 am

Re: Backup not finding sub folders

Post by Swapna »

Hi,

Can you please un-tick the option "Ignore NTFS junction points (reparse points)" from:

Modify profile > Expert > Compare Options > Attribute settings page

and see if it works?

Thank you.
HGCP
Newbie
Newbie
Posts: 1
Joined: Mon Mar 30, 2020 3:09 pm

Re: Backup not finding sub folders

Post by HGCP »

Hi Swapna

I'm having a similar problem which is:

I've strated migrating folders from my work PC's "D" HDD  Drive to the Windows 10 OneDrive directory on the same PC (I don't know whether this is on the SSD, or, HDD), so I can work from home on my laptop.  Anyway, I've started to move some folders (some with several levels of subfolders within the directory tree) from my work desktop's HDD, into the PC's  OneDrive directory.  When I go on to my laptop and login to my Office 365 Home OneDrive account it looks like the folders (and subfolders / subfolders below within the directory tree) all appear with the "cloud" icon saying OneDrive is up to date, BUT  when I open the subfolders there are no files even though though OneDrive says that it is synched...  

Having read some of your advice on this related thread I'm guessing that the solution is what you suggested :

The problem is due to the new OneDrive changes in the Windows 10 Fall creators update. Please un-tick the option "Ignore NTFS junction points (reparse points)" from:

Modify profile > Expert > Compare Options > Attribute settings page

I'm not very IT clued up and I can't find "Modify Profile" in my Onedrive Settings in order to try this fix - please can you help me!

Thanks

Hugo
jack747
Newbie
Newbie
Posts: 1
Joined: Thu Jun 09, 2022 9:15 pm

Re: Backup not finding sub folders

Post by jack747 »

Hi HGCP,
I saw your post after researching the same problem.
Note that the option:
Modify profile > Expert > Compare Options > Attribute settings page
Is an option inside SyncBack, not inside OneDrive.
Open up your SyncBack. Select the backup 'profile' from your list of profiles.
Either press the 'Modify' button from the icons at the bottom of the application window, or right mouse click on the 'profile' row and select 'Modify' from the list of options.
This brings up the modify dialog for the selected profile.
On the left hand side of that dialog there are a list of options. Look at the bottom of the list. If it says 'Expert', click on that. If it says 'Easy', then you're already in the right place.
Look up the list and click on 'Compare Options'.
This opens out a new sub-list. From the sub-list click on 'Attributes'.
Now in the right hand pane you should get a lot of tick boxes. At the bottom of the section 'Attributes' is an option:
[] Ignore NTFS junction points (reparse points)
Remove the tick from the box and press 'Apply' at the bottom of the window.
Now look at the top of the list of options on the left hand side of the window. At the top click on 'Simple'.
You should now see the Source/Destination folders in the right hand pane, and a button 'Choose sub-directories and files'.
If you click on that button, you should now see all the sub-folders, and if it's like mine, they will already be checked for you such that they should be processed next time you run the profile.
Post Reply