Before posting, and to avoid disappointment, please read the following:

  • This forum is not for 2BrightSparks to provide technical support. It's primarily for users to help other users. Do not expect 2BrightSparks to answer any question posted to this forum.
  • If you find a bug in any of our software, please submit a support ticket. It does not matter if you are using our freeware, a beta version or you haven't yet purchased the software. We want to know about any and all bugs so we can fix them as soon as possible. We usually need more information and details from you to reproduce bugs and that is better done via a support ticket and not this forum.

Ignore date & time changes - not working

SyncBackFree is the freeware version of SyncBack. It is *not* an evaluation version of SyncBackPro/SE.
Post Reply
BrownCHiLD
Newbie
Newbie
Posts: 4
Joined: Tue Dec 22, 2009 11:39 am

Ignore date & time changes - not working

Post by BrownCHiLD »

I'm trying mirror my local with my website (via FTP) where there's a few ms time difference causing SyncBack to always sync files even unchanged ones.
so I set the Ignore date and time setting to 30seconds to make sure

Image

yet for some reason SyncBack is still trying to sync already synchronized files due to very small time difference

See:
Image
this file has been synced already and should not be offered again.

I'm using the latest syncbackfree as posting, on windows 10 -> syncing w/ Unix shared web hosting server via FTP.

PS
Or is the syncing due to the attribute differences, and if so , how do i fix that?
mmullins_98
Expert
Expert
Posts: 149
Joined: Wed Jun 05, 2019 11:40 am

Re: Ignore date & time changes - not working

Post by mmullins_98 »

A couple of things that may or may not help.

All of the files on your FTP show 00 seconds so you might try "Ignore date & time changes" set to 60 seconds.

Also as a test set "Ignore file modification date & time changes" just to see if the results are different or not.

"What if a files contents are the same but not the files attributes?
Let's say you have a file in the source and destination, but the attributes are different, e.g. the source file is read-only but the destination file is not. What happens? First, by default, a profile does not compare the attributes of files to see if they're different. To compare attributes you need to go to the Compare Options -> Attributes settings page and choose which attributes you want to compare. For example, you may only care about the hidden and read-only attributes, and so would only enable comparison of those attributes. Keep in mind that some locations, e.g. FTP, don't have Windows file attributes. Also, some file systems, e.g. FAT32, don't have some attributes. In those situations SyncBack will ignore those unsupported attributes and not compare them."
mmullins_98
Expert
Expert
Posts: 149
Joined: Wed Jun 05, 2019 11:40 am

Re: Ignore date & time changes - not working

Post by mmullins_98 »

Suggest you enable the option 'Force the file modification date & time to be correct' under: Modify profile > Expert > Copy/Delete > Advanced page, and see if it helps?
mmullins_98
Expert
Expert
Posts: 149
Joined: Wed Jun 05, 2019 11:40 am

Re: Ignore date & time changes - not working

Post by mmullins_98 »

I see that this option is only available in SyncbackSE & SyncbackPro so you could try one of those to see if the following helps.
Suggest you enable the option 'Force the file modification date & time to be correct' under: Modify profile > Expert > Copy/Delete > Advanced page, and see if it helps?
BrownCHiLD
Newbie
Newbie
Posts: 4
Joined: Tue Dec 22, 2009 11:39 am

Re: Ignore date & time changes - not working

Post by BrownCHiLD »

Thanks but no bueno :(

i tried
"All of the files on your FTP show 00 seconds so you might try "Ignore date & time changes" set to 60 seconds."

-> didnt help..

about
"Also as a test set "Ignore file modification date & time changes" just to see if the results are different or not."
-> this yielded different results, and only files with size difference are being synced... So this proves that syncback time differential fix is really not working


I was thinking about that "Force the file modification date & time to be correct" option but i can't count on this one since I also upload files from my IDE or via FTP manually. So Syncback really needs to deal w/ slight time differences, which isn't seem to be working. Perhaps there's a bug in this current version?
mmullins_98
Expert
Expert
Posts: 149
Joined: Wed Jun 05, 2019 11:40 am

Re: Ignore date & time changes - not working

Post by mmullins_98 »

I do know that some types of FTP do not handle the date correctly. If you post your FTP type the maybe developer Swampa can tell you if your type is one with the problem.

Here is information from developer mickyj :

Listed below are the features that an ideal FTP server should support:

MFMT, SITE UTIME, MDTM

These commands are used to set the last modification date & time of a file. If the FTP server supports MFMT or SITE UTIME then that is ideal. However, some older or less capable FTP server do not support MFMT or SITE UTIME, but may support the MDTM command.

The MDTM command has two functions: to get the last modification date & time of a file, and to set the last modification date & time of a file. Most servers support getting the date & time, but some do not support setting the date & time.

If the FTP server does not support setting a files date & time via MFMT, SITE UTIME, or MDTM then SyncBackSE has two options: to change the local files date & time to match that of the file on the FTP server (the default), or to record the date & time of the local file in the Fast Backup results (you must enable Fast Backup and disable the option "Force the file modification date & time to be correct" on the Copy/Delete tab).

MLSD

This command is used to retrieve the details of all files and directories within a directory on the FTP server. If a server supports this command then SyncBackSE can scan the server considerably faster. If the server does not support this command then SyncBackSE must make two extra calls per file to the server. For example, if a server supports MLSD then only one call to the server is required per directory, but if it doesn't support MLSD then there will be one call to get the list of files and sub-directories, followed by two calls per file in that directory.

MODE Z

A few servers support MODE Z compression. This allows files to be sent to and retrieved from the server in compressed format. For high bandwidth connections it's generally not necessary to use MODE Z compression. Also note that some servers may support MODE Z compression but the administrators of that server may have disabled it (as it uses more CPU time and so could overload the server).

SSL

Some servers support SSL/TLS encryption (implicit and/or explicit). If the server does support it then SyncBackSE can securely send and receive files to and from the server. Note that encryption does impact performance and so should only be used if required. SyncBackPro (not SyncBackSE) also supports SFTP servers, which provide encrypted connections.

UTF

FTP is a text protocol, not binary. Therefore it can have problems with some filenames, e.g. Chinese. To get around this problem some FTP servers accept filenames in UTF-8. UTF-8 is an ASCII-preserving encoding method for Unicode (ISO 10646), the Universal Character Set (UCS). Please note that even though some FTP servers claim to support UTF8, their implementation of it is either broken or partially working.

XCRC

If the server supports the XCRC extension then SyncBackSE can verify that files transferred to or from the server have been transmitted correctly, i.e. the file on the FTP server is the same as the local file based on its CRC value.
BrownCHiLD
Newbie
Newbie
Posts: 4
Joined: Tue Dec 22, 2009 11:39 am

Re: Ignore date & time changes - not working

Post by BrownCHiLD »

i think we're going the long way around on this one if we have to deal w/ server/FTP stuff..

The issue is clear,
Synback is still flagging "small time differences" for backup even though we've set already enough tolerance (60 seconds) .. it's no use complicating the FTP server side and stuff like that when it's clear the simple feature isn't working :( so i guess ill wait till nxt update
Post Reply